Feed on
Posts
Comments
asrock-aptio-uefi

Wooo UEFI IPv6 PXE

I wanted a new Avoton motherboard for my OpenIndiana home NAS with lots of on-board SATA so I could use the PCIe slot for a 10-gigabit NIC. I needed seven SATA ports, six for the data disks and one for the OS drive. The standard mini-ITX configuration seems to max out at six, and I would’ve settled for six plus an on-board M.2 socket but these don’t seem to exist.¬†I ran across ASRock’s C2550D4I board which has 12 on-board SATA via a combination of a couple extra Marvel SATA chips. It’s a little overboard but is as close as I could get.

The out of the box experience wasn’t that great. For whatever reason the VGA port wouldn’t work until I jiggled the connector. My USB keyboard didn’t work after boot until I unplugged it and plugged it right back in immediately after POST. Then after the system came up one of the Marvel chips didn’t come online or something which marked four disks offline and made my zpool sad.

On the second boot zpool was happy but VGA and USB was still touchy.¬†Upgrading the BMC and UEFI firmware seemed to help with VGA, but keyboard was still not reliable. Other than that the system has been up and solid now. I got serial-over-LAN support working for POST and GRUB, but for the life of me I can’t serial console to work in OpenIndiana/illumos on ttya, ttyb, ttyc. poop.

The good thing that surprised me about this board is that it supports UEFI IPv6 PXE. Not even my SuperMicro Avoton or my brand new Xeon-D board do this. This would let a person completely install the system on a v6-only network. So I guess if you care about IPv6, buy ASRock boards for now.

edit: this seems to be because the ASRock board uses the Intel i210 Ethernet controller instead of the interfaces built into the SoCs. I suspect the SoC for both the Avoton C2550 and Xeon D-1520s don’t have UEFI drivers for the interfaces that support this.

Leave a Reply